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1. Introduction
Profiler Software / Component Profile Tool Overview
The Component Profile Tool and Profiler software contain all the components required to create and modify the .xml profiles 
that RacePoint Blueprint uses when communicating with the components in its Component Library.

The Profiler software is installed onto the Savant Development Environment (MacBook®) and is opened through the Savant 
Application Manager (SAM). The Component Profile Tool and Profiler software work together to create and modify the .xml 
profiles used in RacePoint Blueprint®.

.xml profile 
A profile is an .xml file. Within this .xml file is a list of characteristics specific to a piece of equipment or device such as a 
DVD player, television, blu-ray player, and a host of other products that can be controlled using the Savant Control System. 
Information such as volume up, volume down, power on, and power off are just a few of the potentially hundreds of 
characteristics that make up the profile. Any piece of equipment that will be controlled by the Savant Control System will 
require a profile. For additional information on what a profile is, how the file is structured, and how it functionally works with 
RacePoint Blueprint, refer to the Component Profile Developers Guide - Part 1 and Part 2

When adding a piece of equipment to the Savant Control System that is currently not part of the RacePoint Blueprint® 
Component Library, one of the two methods below must be employed.

1. Utilizing an existing profile - Use an existing .xml profile from a piece of equipment that already exists in the 
Component Library of the RacePoint Blueprint Component Library. This existing profile was originally created for a 
product that is similar but not the exact. An example would be two TVs made by the same manufacturer. One is a 22 inch 
model and the second is a 36 inch model. In this case the existing profile in RacePoint Blueprint will probably work but 
minor modifications may be required.

2. Create a new profile - No profile for the equipment exists and a profile needs to be created from scratch using the 
Profiler software.

3. Testing a profile - Any profile that is created or modified can be tested to verify it works as required.

In all cases, the Savant Profiler software can be used. The Savant Profiler is a software tool that gives users the ability to 
create or modify profiles. Once the profile has been created or modified, it is then saved into a User Library that you create. 
The User Library and all created profiles can then be dragged into the RacePoint Blueprint application for use. 

Reference Guide Overview
This reference guide starts by describing the features of the Profiler software and how it is used to create a profile. It then 
describes how a Savant controller is used to create, modify, and test an existing profile. Refer to either the Table Of 
Contents or the Checklist in the next section to navigate to the specific section of the guide.
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2. Reference Guide Checklist
Use the checklist below to navigate through the Reference Guide.

1. .........................................................................................Install and Start Profiler Software 
A.  Install Profiler Software
B.  Start Profiler Software

2. ...................................................Create a Profile - Create a Profile using Profiler Software 
A.  Gather Product Information 
B.  Configure Profile Info Tab (Step 1)
C.  Configure Control Interfaces Tab (Step 2)
D.  Configure Inputs and Outputs Tab (Step 3)
E.  Configure Default Assignments Tab (Step 4)

3. ....................................................................................................................Testing a Profile 
A.  Testing a Profile - Hardware Connections
B.  Testing a Profile - Create a User Library
C.  Testing a Profile - Configure Resource Actions tab to send commands

4. .....................................................................................................................Modify a Profile 
A.  Modify a Profile - Hardware Connections
B.  Modify a Profile - Load profile into User Library
C.  Modify a Profile - Configure Resource Actions tab to collect the IR Commands

Component Profiler Tool and Profiler Software Reference Guide 
Software Reference Guide Copyright © 2015 Savant Systems, LLC

009-1292-02  |  150320 4 of 37



3. Before You Begin
Requirements
Requirement Description

Supported Operating Systems Refer to the Quick Reference Guide (QRG) of the Component Profile Tool for OS 
information

Supported Releases da Vinci 5.2.2 or higher

Supported Controllers
To test and modify the .xml profiles, the Profiler software communicates with the various 3rd party devices through a Savant 
controller. The table below displays the Savant controllers that have been tested and known to work with the Profiler 
software. 

Controller
• Savant SmartControl 7 (SSC-0007-xx) - da Vinci 5.2.2 or higher
• Savant SmartControl 8 (SSC-0008-xx) - da Vinci 5.2.2 or higher
• Savant SmartControl 12 (SSC-0012-xx) - da Vinci 7.0
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4. Install Profiler Software
The Savant Profiler software tool is installed with the da Vinci software. Once the da Vinci software has been installed, the 
Profiler can be opened.

 Important !!! 
The Profiler software is installed onto the Savant Development Environment (MacBook®) when the Savant da Vinci 
software is installed. It is important that the da Vinci software get installed using the Savant Application Manager (SAM). 
Once installed, the Profiler software as well as the utilities such as RPMTerminal and RPMEmbeddedScanner must all be 
launched through the Savant Application Manager. To do this, from the SAM menu bar, select Launch and scroll to the 
utility to open. 

For reference, all software utilities installed on the Savant Development Environment (MacBook) are located here: 

Macintosh HD > Users > (Mac User info) > Applications > RacePointMedia > Savant Profiler.app

Start Profiler Software
To open the Profiler, either select the Profiler Icon  from the Savant Application Manager window or select the Profiler 
icon from the Launch drop-down menu as shown above.
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5. Profiler General Knowledge
The drop-down fields from the Savant Profiler menu bar are described in the section below.

File Menu
The File drop-down menu is described below. Only menu items that are specific to the Profiler Tool are described in the 
table below. However, general functions such as Print and Page Setup all still work.

Menu Item Description
New Profile Opens a new instance of the Profiler software to begin creating a new .xml profile.

Open Open an existing profile. Selecting Open will open a Finder window. Once open, you can browse to the 
appropriate profile.

Open from Library
Opens a new window labeled Open from Library. The main system library from Blueprint is listed as well as 
any user libraries created. This is a good tool for opening, locating, and modifying an existing .xml profile to 
work with the device being added to the Savant Control System.

Open Recent Opens a second drop-down menu with all the profiles that were recently worked on or opened. A Clear Menu 
field is available to clear all recent files from the drop-down menu. 

Close Close the Savant Profiler application

Save Save the .xml profile currently displayed in the Profiler software.

Duplicate
Creates a duplicate copy of the Profiler software with the profile loaded into the Profiler. The duplicate created is 
given a new version number. You cannot save the duplicate profile until notes are created in the Profile Notes 
window describing the changes made.

Revert To Opens a drop-down menu that lists all the previous versions of the profile currently loaded along with last time 
the version was saved. Allows a user to go back to previous versions for troubleshooting purposes.

Edit Menu
The Edit Menu drop-down menu is described below. Only menu items that are specific to the Profiler Tool are described in 
the table below. However, general functions such as cut and paste all still work.

Menu Item Description

Open IR Translator Opens the IR Translator tool. Refer to the IR Translator section below for more information on using the IR 
Translator

Test Command When a command in the Command Table is selected, the Test Command menu item will send the 
command to the device selected in the drop-down menu of the IR Capture Device box.

Move Profile to Trash The Move Profile to Trash is grayed out until a profile is selected. Once a profile is selected, (typically 
during an Open or Open Recent command) choosing Edit > Move Profile to Trash will delete the profile. 
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Window Menu
The Window drop-down menu is described below. Only menu items that are specific to the Profiler Tool are described in the 
table below. However, general functions such as minimize and zoom all still work.

Menu Item Description

Profile Libraries Opens a Profile Libraries window. The System Library is automatically displayed along with any User 
Libraries created.

Additional Information on Profile Libraries
There are two types of libraries that handle profiles. Those libraries are described below along with how to add and remove 
libraries from the Profiler.

A  System Library - The System Library contains all profiles distributed with the software release. These profiles are 
available with each component in the component library in RacePoint Blueprint.

B  User Library - The second library type is the User Library. The User Library is initially created by the user and should 
contain the profiles you create or update. A User Library is added to the Profiler by selecting from the menu bar File > Open 
from Library and the Open from Library window appears as shown below. Adding the User Library to RacePoint Blueprint 
is described in the next section labeled Add User Libraries to RacePoint Blueprint.

C  Adding and Removing Libraries - To add a directory to the Libraries box, select the  . This will open a Finder 
window. Browse to the directory where the user created profiles are saved, select it, and press the Open button. The 
directory will be now be added as a User Library. All custom profiles stored in this directory will be displayed in the Profiles 
box to the right. To remove a library, highlight the library and click the . This will remove the chosen library.

The Profile Library can also be accessed by selecting Window > Profile Library from the menu bar.

• A directory can also be added to the Profile Library by dragging and dropping the directory into the Libraries box.
• Hover over each directory in the Libraries box, this will display the path to that specific library.
• A profile from the System Library can be dragged and dropped into a User Library. Once in the User Library, it can be 

modified.
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Add User Libraries to RacePoint Blueprint
Each User Library created can then be added to RacePoint Blueprint. Once added, the profiles added are available for use 
through the Component Library in RacePoint Blueprint. 

To add a user library to RacePoint Blueprint, do the following:

1. Create a directory on your MacBook. Label it Custom XML Profiles or something similar.
2. Open the RacePoint Blueprint application.
3. From the menu bar, select RacePoint BluePrint > Preferences and the RacePoint Blueprint Preferences window 

appears.
4. Select the Libraries icon.
5. Add the Custom XML Profiles directory to the table shown below. To do this, drag and drop the Custom XML Profiles 

directory you created in step 1 into the Libraries window shown below. This will add the directory to the library along with 
a path to it. Refer to window below.  

Note: The User directory can also be added to the RacePoint Blueprint profiles libraries. 

• Select   from the Preferences window. A browse window will appear. 
• Browse to and select the custom .xml profiles directory you previously created. The directory along with all .xml profiles will 

be added.

Share Menu
The Share drop-down menu is described below. The table below describes each field.

Menu Item Description

Send via Mail A .zip file containing the .xml profile, a verification report, and icon file are copied into an email message. 
For this function to work, email must be configured for the current user.

Export XML File The .xml profile is copied to a Save window. From the Save window, browse and select a directory to save 
the profile. This is an alternative to saving the profile into the Profile User Library described above.

Mail Verification Report

Selecting Mail Verification Report will open a new email window with the following recipient:
To:  

The email will include a verificationReport.zip file. This file includes the following:
• An icon file that displays the 3rd party equipment the profile is being created or modified for.
• The .xml profile with all modifications made
• A verification report that displays the tests run during the testing of the profile

Send Report to Savant

Selecting Send Report to Savant will send the same report described above in the Mail Verification 
Report section to the Support Team through the Savant Portal. The Send Report to Savant feature is an 
easy way to share a created or modified profile with Savant.
In addition to sending the report, a user can also create a Support Ticket. The Support Ticket will be 
created for the profile you are having issues with.
Note: Report data is persistently stored, auto-saved, and follows the profile as it is moved between libraries 
or exported to a directory.
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Step Indicator Tabs
The Step Indicator tabs on the Profiler aid a user when creating a profile. Start with the Profile Info tab and work down the 
Step Indicator Tabs to create a profile. Selecting the Profile Info tab opens the window shown below. Each section of the 
Profile Info tab is described in the table.

Profile Info Tab

A Step Indicator 
tabs

To create a profile, a sequence of steps must be followed. The Step Indicator tabs allow a user to move 
through steps 1-5. As each tab is selected, information on the device or piece of equipment must be entered 
into the appropriate fields. To move to the next tab, select the next tab in the list or click the Next button.

B Title Bar

When starting a profile, the title bar will display Untitled. After the profile is built and saved, the title bar will 
display: Manufacturer - Model - Device type - User Library

Click the Disclosure Triangle and a dialog box appears with the following selections: 
Duplicate - Duplicate the existing profile and automatically up-rev the revision.
Lock - Locks the .xml profile being created. When trying to save a locked file, a dialog box opens informing 
the user the file is locked. From the dialog box, the user can unlock the file or create a duplicate file to work 
with.
Browse All Versions - Allows a user the ability to open earlier saved versions of the profile.

C Device 
Information

High level information about the device that the user must enter. This information will all be added to the 
profile being created.
Device Type - The device selected from the Device Type drop-down menu.
Manufacturer - The device selected from the Manufacturer drop-down menu.
Model - Model number of device entered in the Model field.
Alias (optional) - Enter additional information that describe the device. This field is optional.
Zones - On multi-zone devices like a two or three zone receiver, select from the drop-down menu, the 
number of zones supported on the device. Up to 16 zones are supported per component profile.

D Zone Names 
(optional)

Each Zone on the device is automatically labeled by the Profiler. The Zone Names field should rarely be 
modified. 
Note: The Profiler populates the Zone Names field based on the device class of the profile. Modifying the 
Zone Name, changes the logical component name which also changes the name of the states and service 
requests the profile produces since the state names are formatted as: 
<component name>.<logical component name>.<state name>

E Image 
Placeholder

An image of the device can be added by dragging and dropping the image into the Image Placeholder box. 
Most image formats such as JPEGs, GIFs, and PNGs are supported. To remove the image, select the 
image and choose Edit > Delete from the Profiler menu bar.

F Profile Notes The Profile Notes window displays versioning information as well as any notes that a user adds. The notes 
are then added to the .xml profile.

Note: All fields in the Profile Info tab need to be populated before moving to the Control Interfaces tab.
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Control Interfaces Tab
The Control Interfaces tab specifies the properties of the 3rd party component's control interfaces. The three control 
interfaces supported are RS-232, IR, or IP. One or all interfaces can be selected at one time as long as the controller 
supports the interface. The information configured in this window is typically available on the manufacturer’s website.

RS-232

Connector Type - Select the type of connector installed on the device being controlled.

RS-232

Name On Device - Enter a name that matches the label or silkscreen for the RS-232 port on the device being 
controlled.

RS-232

Flow Control - Select from drop-down menu the Flow Control specified for the RS-232 port of device being controlled.

RS-232

RS-232 Cable Type - The cable that connects the device to the Savant Control system is specified here. Depending on 
your setup, a Straight-Thru, Null Modem, or Custom cable is required. 

A RS-232

Default Baud Rate - The Baud Rate specified is the rate of transfer of the RS-232 data stream between the device and 
the Savant Control System. The baud rate specified for the device should be selected.

A RS-232 Supported Baud Rate - If the device supports more than one baud rate, additional baud rates can be selected as a 
Supported Baud Rate. For example, a device may have a default rate of 115200 but allows you to change the baud rate 
to 9600. In this case, you should select the Default Baud Rate to be 115200. You can then select the baud rate 9600 
from the Supported Baud Rate drop-down menu. This will set the Default Baud Rate as 115200 and 9600 will also be 
available in RacePoint Blueprint. Multiple baud rates can be selected and the Default Baud Rate cannot be disabled. 
Note: Lower baud rates improve data transmission over long cable runs.

RS-232

Parity - Select the parity bits as either None, Odd, or Even. Select whatever is specified for the device.

RS-232

Stop Bits - Select from drop-down menu the number of Stop Bits specified on the device.

RS-232

Data Bits - Select from drop-down menu the number of Data Bits specified on the device.

IP

Name On Device - Enter the Name that identifies the IP connection. Typically the name entered matches the label or 
silkscreen for the IP port of the device being controlled.

B IP

Protocol - Select the protocol that is configured on the IP port of the device being controlled.
TCP (Default) - IP protocol when controlling IP devices. TCP does not specify a default port number. 
HTTP - Default port is 80. In some cases 8080.
Telnet - Default port is 23.
UDP - UDP does not specify a default port.
Non Persistant TCP - As in TCP, no default port is specified

IP

Port - The port can be a value from 1 to 65535. It is an integer but should be formatted without a thousands separator. 
Different protocols have default port values.

C IR The device supports Infrared signals such as signals coming from a remote.

Note: All fields in the Control Interfaces tab need to be populated before moving to the Inputs and Outputs tab.
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Inputs and Outputs Tab
The Inputs & Outputs window is where the physical inputs and outputs on the device are configured into the profile. 

A Click + to add an input or output port to the .xml profile. The input or output being added will appear in the 
Inputs and Outputs table. Once in the table, it can be modified.

B Inputs and 
Outputs

The Input and Output connections appear in this table when being added. Once added to the table, the 
name and characteristics of the connection can be modified. The columns are described below.
Name On Component - Once the Input/Output has been added, double click the default name that appears 
in the Name On Component field. This will highlight the name and allow the user to modify.
Direction - Select whether the connection is an Input, Output, or Internal. Refer to the Additional 
Information section below for more information on the Internal setting.
Zone Assignment - The Zone Assignment can only be configured on an output connection. Any previous 
Zone Names defined in the Profiles Info tab above can be selected from the drop-down menu. 

C
Connections and 
Resources for 
Selected Ports

The Connections and Resources for Selected Ports table adds services and resources to the Inputs and 
Outputs added. Click each box that pertains to the connection being added. 

Additional Information:
Zone Assignments

• Zone Assignments only apply to output connections.
• The Zone Assignment field can be configured on more than one physical output connection. For example, two separate 

outputs, one labeled ZONE 2 PREOUT and second labeled ZONE 2 SPEAKERS, can both be assigned to the same 
zone.

Internal Inputs
• Internal inputs are not physical inputs on a device. An internal input is a virtual input but behaves like a physical input. 

Examples of Internal inputs would be the following:
- A DVD player built into a TV. The DVD player will have a discrete command to select the DVD player input.
- A media server built into a device.
- Apps on a TV that have discrete commands that transfer directly to the App.

Resources
• The Resources associated with an input or output determine which services RacePoint Blueprint will generate when the 

inputs and outputs are connected. Typically, source devices like DVD players have their resources on their outputs. Sink 
devices, such as displays, have resources on their inputs. 

- For example, a Blu-ray player will have the resources Enhanced Definition DVD, DVD, and CD on both its audio and 
video outputs. Receivers have the volume control resource on their outputs because the volume function occurs on 
the outputs. However, on a display that has speakers (which may not have any output connectors) the volume control 
resource will be put on the inputs.

- Lighting and Shade resources are reserved for lighting and shade controller device class devices, and do not follow 
the same A/V path resource logic. They are simply enabled or disabled for the whole component profile. 
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Default Assignments Tab
The Default Assignments tab is used on devices that typically have a physical input or inputs that are by default, mapped 
to a virtual source such as DVD or SAT/CBL. A device such as a DVD player that are strictly source (output) devices do not 
have default assignments configured in them. 

The default assignment is set internally on each product so any time the virtual source is selected (like in an on screen 
display or physical button on the device), the source selected is linked to a physical input. The electronic connection made 
when selecting a virtual source is termed the Default Assignment.

Example:
An Audio/Video receiver has two A/V input connections labeled HDMI 1 and HDMI 2. In this receiver there are also two 
virtual sources selectable through an on screen display. They are labeled SAT/CBL and Blu-ray. Each time the source SAT/
CBL is selected, the audio and video signal coming into the HDMI 1 input will be played through the receiver. If the source 
Blu-ray is selected, the audio and video signaling coming into the Blu-ray player will be played through the receiver. Each 
connection made uses the default assignment configured internal to the Audio/Video receiver. This determines which input 
will be played. 

The Default Assignments in each device needs to be configured in the Default Assignments tab shown below.

A Default 
Assignments

Input Name - The Input Name field is automatically populated with the input connections configured in the 
Inputs and Outputs Tab (Step 3). 

A Default 
Assignments Default Assignment - Enter the virtual source that is linked to the specific input displayed in the Input Name 

field. In the Default Assignment window shown above, CBL/SAT is linked to HDMI 1 and Blu-ray is linked to 
HDMI 2.

B Additional 
Assignable Inputs

The Audio/Video receiver may also support assigning additional input names. These are assignments that 
exist in addition to the assignments defined as a default assignment but do not have any physical inputs 
assigned to them. 

Any additional assignable inputs created will be available in RacePoint Blueprint. Once available, you can 
modify the assignment of an input from one logical input to another. For example, the receiver may have 
HDMI 2 programmed to the SAT/CBL input. In this scenario, the assignment of the SAT/CBL can be modified 
using Blueprint instead of having to reprogram the receiver to use its default input.
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Resource Actions Tab
The Resource Actions tab is used to for the following:

• Test a profile by sending commands to a device using the IR Interface. 
• Test a profile by sending commands to a device using the RS-232 Interface.
• Test a profile by sending commands to a device using the IP Interface.
• Capture commands (PowerOn, PowerOff, etc.) directly to the RPMTerminal.

A Command Table

When a profile is loaded into the Profiler, all the commands in that profile are listed here. The table is 
separated into sections making it easy to locate a specific command. 
Action Column - Displays the commands available from the .xml profile loaded into the Profiler software. 
These could also be used as a single step in a workflow.
Repeat - This column is not used for testing. The Repeat Column is the number of times the command is 
sent when the command is part of a workflow. To modify the value in the Repeat column, press the  
buttons. During testing, to send the command out three times, the Test button needs to be pressed three 
times.
Delay Column - The delay is NOT used when testing the profile. The Delay entered sets a time in 
milliseconds between the command in the Action Column being sent and the next command in a workflow 
being transmitted.
Test Column - Pressing the Test button sends the command string out the port selected in the Interface 
field of Command Output Selection Box. The Command String column contains a string of hex data (Not 
shown in window above). If there is no string displayed in this row, no command will be sent when Test is 
pressed.

Note: The command strings are typically available through the manufacturer of the device.

B
Command Output 
Selection Box

Interface - This will display any control interfaces defined in the control interfaces section configured in the 
Controller Interfaces section above. The selections are IR, RS-232, and IP.
Zone - The Zones of the product being controlled are listed in this drop-down menu. This menu is used to 
filter the number of commands displayed in the Command Table shown above.
Resource - All the Resources selected in the Inputs and Outputs tab will be listed in this drop-down menu.  
Select a resource to filter the number of commands listed in the Command Table.

C
IR Capture/RS-232 
Configuration Box

This box is a dual function box:
• When IR is selected, a drop-down menu where you can choose the IR Capture Device such as the 

Global Cache IR Capture Device will be visible. Refer to the IR Translator section for information on 
capturing IR commands from a device such as a remote control to a TV.

• When RS-232 is selected in the Interface drop-down menu, a Command Prefix and Command Postfix 
box appears allowing you to add characters to the beginning and end of the command string sent to the 
device being controlled.

IR Capture/RS-232 
Configuration Box

Start Capture - Press the Start Capture button to initiate the connection to the controller and RPMTerminal.
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Profile Verification

The Profile Verification section is a way to keep track of which commands have been tested and whether 
they function as required. After testing a command, clicking the Test State Box will change the will change 
the color of the box.

Green - Command works when sent to the device.
Red - Command doesn’t work when sent to the device. Command needs modifications.
Gray - Command hasn’t been tested.

D Profile Verification

In addition to the green, red, and gray indicator boxes, a user can also enter comments about each 
command as well. Clicking the …. in each command field will open an Expected Results dialog window. In 
this window, information such as what is expected to happen and the actual results can be documented. 

A report of the profile along with all updates and comments made can be sent to Savant for further analysis 
by the Savant Technical Support team. To submit a report, select Send Report to Savant from the Share 
menu. Refer to the Share Menu section in this document for more information on sending reports for 
analysis.

Note: Report data is persistently stored, auto-saved, and follows the profile as it is moved between libraries 
or exported to a directory.
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6. Creating a Profile (Example)
The information below walks you through creating a .xml profile.

Gather Product Information
The first step is to gather information about the product. In this example, a .xml profile for an LG High Definition Television is 
created. 

Inputs Outputs
RF Video Digital Audio Out (Optical)

Component Video (Y, Pb, Pr) + Audio Composite Video Output (DVD/VCR)

RGB In (D-Sub 15 pin) - PC

PC Audio

RS-232C (DB-9)

Audio/Video (Composite)

HDMI® / HDCP

USB 2.0

Once the information has been gathered you are ready to open the Profiler and create the profile. For demonstration 
purposes, the procedure below describes how to create just a few of the connections shown in the table above.

Start Profiler Software
To open the Profiler, refer to the Starting Profiler Software section above. The Profiler will open to the Profile Info window.

Configure Profile Info Tab (Step 1)
1. Select the Choose Type button. In the window that appears, select a device. If your device is not displayed, select a 

device that is closest to the product that the profile is being created for. For example, in this procedure HD Monitor was 
chosen since a High Definition Television is not listed.

Source Devices - Components that provide content that you watch or listen to.
Sink Devices - Component that the source devices play to.
Multi-Zone Devices - Components that can play separate audio sources to multiple rooms.

2. In the Manufacturer: field, select the Choose Manufacturer button. Scroll to and select the manufacturer. 
Note: If the manufacturer is not in the list, a custom manufacturer can be added. Select Add New Manufacturer 
from the list. In the window that appears, enter a name of the new manufacturer. The new manufacturer will be added 
at the top of the list in its own separate section.

3. Enter the model number of the product into the Model: field.
4. (Optional:) Enter into the Alias (optional) field, text to identify the product.
5. In the Zones drop-down menu, select the number of zones supported on the new device. This will also be reflected in the 

Zone Names (optional) field table below it. It is recommended that any zone names that are automatically populated by 
the Profiler be accepted and not modified. In this procedure, only one zone exists and the profiler automatically labeled it 
HD Monitor.

6. Drag an image file of the product into the Drag Device Image box. Most image files (png, jpg, tiff, etc) are supported.
7. The Profile Info window is complete. Continue on and select the Control Interfaces tab.
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Configure Control Interfaces Tab (Step 2)
As described in the Control Interfaces Tab general knowledge section above, the Control interfaces tab configures which 
interfaces on the equipment are used communicate with the Savant controller in the system. This is a control interface and 
all commands to and from the product are transmitted through these connections.

1. Enter a checkmark into one or more of the Control Interface boxes along the top of the Control Interfaces window. The 
HD TV accepts both IR and RS-232 commands so both are checked in the image below.

• In the example, the equipment can be controlled through an RS-232 port or an IR port so both were checked. 
Note: Once RS-232 is selected, the fields below it must be configured to the specifications of the product. This 
information is typically found in a manufacturers specification table or through a support website. 

Refer to the Control Interfaces Tab above for information on the individual fields within each column in the Control 
Interface window displayed above.

2. When the interfaces have been configured, select the Inputs and Outputs tab.
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Configure Inputs and Outputs Tab (Step 3)
The Inputs and Outputs tab is where the input and output connections on the equipment being controlled is configured. 
The steps below describe adding a couple of connections from the High Definition Television above. These connections are 
displayed in the Gather Product Information table above. For demonstration purposes, only two of the connections are 
explained.

Configure the HDMI IN connection (INPUT)
The procedure below configures an INPUT.

 Important !!!
• In most instances the Profiler Tool automatically populates the required boxes in the Audio, Video, and Resources 

columns. However, in some instances, the user creating the profile may need to manually add checks to boxes. This 
is shown in the example below.

• For additional information on each of the settings and fields referenced in the procedure below, refer to the Inputs and 
Outputs Tab information in the general knowledge section above.

1. At the bottom of the Inputs & Outputs table, select   to add a new connection.
2. Change the connection added to the Name On Component field to match the label or silkscreen that corresponds to 

the connection being added.
3. In the Direction column, select from the drop-down menu whether the connection is an Input, Output, or Internal. 

Input was selected since this is a audio/video input.
4. The Zone Assignments column is for Outputs only so it is not used in this example.
5. In the Connections and Resources for Selected Port table, the following was checked:

• HDMI Audio was selected from the Audio Connections column. This automatically adds a check to the Amplifier, 
Stereo Speakers, and Volume Control boxes in the Resources column.

• HDMI was selected from the Video Connections column. This automatically adds a check to the AV Monitor box in 
the Resources column.

6. The HDMI IN connection is complete.
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Configure a HEADPHONE Connection (OUTPUT)
The procedure below configures an OUTPUT.

1. At the bottom of the Inputs & Outputs table, select   to add a new connection.
2. Change the connection added to the Name On Component field to match the label or silkscreen that corresponds to 

the connection being added.
3. In the Direction column, select from drop-down menu whether the connection is an Input, Output, or Internal. 

Output was selected since this is an audio output.
4. In the Zone Assignments column, the zone is automatically selected. If you prefer a different zone, select it from the 

drop-down menu.
5. In the Audio Connections field, Analog Minijack (⅛”) was checked.
6. In the Resources column, Volume Control was checked since the volume can be controlled to the headphones.
7. The HEADPHONE IN connection is complete.
8. Continue to add all connections to the TV. 

For more information, refer to the Inputs and Output  section in the general knowledge section above.
9. Continue to the next step which is configuring the Default Assignments.

Configure Default Assignments (Step 4)
Add any Default Assignments to the available inputs. Since the device being configured is a sink device and the Default 
Assignments are commonly configured on a source device such as an A/V receiver, there are no Default Assignments 
required. If Default Assignments were being added, refer to the Default Assignments section above for more information.
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Save Configuration
The .xml profile configuration is now complete. The configuration created should now be saved into a user directory that is 
created specifically for the .xml profiles created or updated. Follow the steps below to save the .xml profile.

1. Create a directory on your MacBook (SDE) that will contain all your custom profiles. In this example, a directory was 
placed onto the Desktop and it was labeled Custom_Profiles.

2. Go to the menu bar and select File > Save… A window like below will appear.

3. Select the  from the Libraries window. In the Open window that appears, browse to the Custom_Profiles directory  
created above and select the Open button. The directory will now get added to the Libraries window.

4. Enter notes into the Change Log window. Once notes are entered, the Save button becomes active and can now be 
selected. 

5. Click the Save button and the profile along with any images added will be saved into the directory created for the 
custom profiles. 

The profile created above can now be tested. The testing is all done through the Resource Actions tab. 
Before starting the testing, the hardware needs to be setup for testing and modifying the commands. 
Continue to the next section for information on connecting, testing and modifying a .xml profile. 
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7. Testing/Modifying Profiles Overview
To test and modify .xml Profiles, some basic equipment is required:

• Savant Development Environment (SDE/MacBook®)
• Savant controller (Refer to the Supported Controllers section)
• Ethernet Cabling
• Local Network
• Profiler software loaded on SDE/MacBook.
• Control Cable (IR Repeater/Flasher, RS-232 cable with required Adapter, or Ethernet straight-thru cable).

Note: IR commands can be downloaded from the manufacturer and translated to a format that the Profiler software accepts. 
For information on translating IR commands, refer to the Translating an IR command in Appendix C:
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Testing a Profile - Hardware Connections
Connect the hardware diagram shown below. Note that in the diagram, all possible controller port connections (IR, RS-232, 
and IP) are displayed. When testing a .xml profile, only one of the controller ports is necessary. 

• Connect an Ethernet cable from the Ethernet port on the rear of the MacBook to the Ethernet port of a switch, hub, or 
router installed in a local network.

• IR Port Testing - To test a component through the IR port, connect the IR Repeater/Flasher to an IR port on the rear 
of the Savant controller. The IR Repeater/Flasher can be plugged into any IR port. The port number the Repeater/
Flasher is plugged into is selected later during the testing process. Point the Repeater/Flasher towards the device 
the profile is being tested against.

• RS-232 Port Testing - To test a component through the RS-232 port, connect an RS-232 cable from either RS-232 
port 1 or port 2 on the Savant controller to the RS-232 port on the device the .xml profile is being tested against. 
Before plugging into the RS-232 port on the 3rd party device, verify whether a Savant Adapter is required. For 
information on the adapters offered through Savant and how each adapter is wired, refer to the Appendix A - RS232 
section in this document.

• RJ-45 Port Testing (Ethernet) - To test a component through the Ethernet port, plug an Ethernet cable from the 
Ethernet switch, hub, or router to the RJ-45 controller port on the device the .xml profile is being tested against.

• After all connections are made, apply power to the Savant controller by plugging the power supply adapter into a 120V AC 
wall outlet. 

Additional Information
• Turn off Wi-Fi® on the MacBook. The Wi-Fi network on the MacBook interferes with the Profiler software and connection 

issues may occur. If Wi-Fi is turned on, the Profiler software will display the following error.

• In the network settings of the laptop, all network controllers should be disabled except the Ethernet service.
• If the MacBook is running Parallels®, the network services within the application must be disabled.
• The Ethernet switch/hub in the local network should NOT be a managed switch which has services such as spanning tree 

or VLANS. These services interfere with the communications. A simple unmanaged Ethernet switch or Ethernet hub is 
recommended. 

• The MacBook, controller, and UUT should all be on the same subnet when testing.
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Testing a Profile - Without Automator
Profiles may be tested directly from the host without using Automator by running a command.  After connecting the hardware 
(see Testing a Profile - Hardware Connections), refer to the Testing Component Actions Without Automator Application 
Note located on the Savant Community for details.

Testing a Profile - User Library
Once the hardware is connected, the steps below describe testing a .xml profile taken from the Component / System 
Library in RacePoint Blueprint. The profile in RacePoint Blueprint is copied from the existing Component / System Library 
and loaded into a User Library that the user creates. The .xml profiles are copied to the User Library since the .xml profiles 
in the Component/System Library cannot be modified.

Create a User Library

 IMPORTANT!!!
The Profiler software needs to be started through the Savant Application Manager (SAM). Starting the Profiler software 
using anything other than SAM can produce erroneous network issues. Always start the Profiler through the Savant 
Application Manager (SAM).

1. Refer to the Install Profiler Software section for information on installing and starting the Profiler software.
2. Create a directory (User Library) on your MacBook (SDE) that will be used to store the custom profiles. Create the 

directory in a place that you can access it through the Profiler software. Refer to the Window Menu section above for 
information on the different libraries.

3. Once the directory (User Library) is created, RacePoint Blueprint is then configured to reference the User Library 
for custom .xml profiles. To do this, refer to the Add User Libraries to RacePoint Blueprint section above.

Copy Profile from System Library to User Library
1. From the Profiler menu bar, navigate to File > Open from Library. In the Open From Library window, you can do 

one of the following:
• If the .xml profile being tested has already been copied to the User Library, highlight the User Library and double 

click the .xml profile. This will open a new Profiler window with the selected .xml profile loaded.
• If the profile is NOT already loaded into the User Library, it must be copied there. The next few steps describe how 

to copy a .xml profile from the System Library to the User Library:
- Select the System Library and a list of .xml profiles will appear in the Profiles window.
- Search the Profiles window and find the .xml profile to be modified.
- Select and drag the .xml profile from the System Library into the User Library. 

2. With the .xml profile now loaded in the User Library, select and highlight the User Library. The .xml profile just 
copied from the System Library will be available. Select the .xml profile and select the Open button. This will open 
the profile into a new Profiler window.
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Testing a Profile - Configure Resource Actions Tab to send commands
With the profile loaded and saved in the User Library, it can now be tested. The section below will describe how to send 
commands to the device the profile is being tested against and view the commands using RPMTerminal.
Note: If there is a Savant host on the network and it is using the controller for other functions, the software running on the 
host must first be stopped before continuing. 

1. In the Profiler software, select the Resource Actions tab.
2. From the Interface drop-down menu, select the port on the Savant controller that the commands will be sent 

through. In this example, IR was selected. 
3. In the table that lists all the commands, find the command you would like to test. The Zone and Resource drop-down 

menus are available to filter the number of commands displayed in the table. Refer to image below.

4. Once the command is located, select the Test button for the command. This will start the process of locating the  
Savant controller. The Profiler will scan the local network and display all the Savant products on the network. Locate 
the controller through the UID and product name and select it. The Controller drop-down menu will automatically 
populate the Savant controller selected. The image below selects the SSC-0012 controller. This however could be 
any of the Supported Savant Controllers in the network.

5. In the Control Port drop-down menu, select the IR Port the Repeater/Flasher is plugged into.
6. At this point, the RPMTerminal utility has opened and is now minimized to the docking station of the MacBook. Click 

the RPMTerminal application to open.
7. Select the Launch System button. The RPMTerminal will begin the process of connecting to the Profiler and 

Controller. RPMTerminal Launching is displayed just above the table displaying the profile commands.
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8. Once connected, RPMTerminal Connected is displayed. and the RPMTerminal will display the connection process.

An RPMTerminal will open and display the controller connected to it.

9. To test a command, go back to the Profiler software and press the Test button next to the command you would like to 
send. The command selected is sent through the IR port to the device the profile is being tested against. If the 
hardware is connected properly, the command is sent and the 3rd party device should act accordingly. 

10. To verify the command is being sent, view the RPMTerminal. A string of digits will be displayed each time the test 
button is pressed. The terminal below shows a few different commands being sent.

11. Send any command by pressing the Test button and verifying the command is executed correctly. If any of the 
commands do not work, they can be updated by capturing the commands using the Global Cache IR reader supplied 
with the kit. This is described in the Capture Commands to Profiler section below.
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Modify a Profile - Capture commands to Profiler
The best method of creating an IR profile is to capture the codes directly from a 3rd party remote. This can be accomplished 
by sending commands through a Global Cache IR Learner, which are then translated and passed directly to the Command 
String field of the Profiler Tool.

Note: If you have manufacturing IR codes and need to translate them before adding to the Profiler, refer to Appendix C: IR 
Translator.

Connect Hardware
Connect the hardware. 

1. Connect the Ethernet port from MacBook to a network switch, router, or hub.
2. Connect the Ethernet cable from network switch, router, or hub to Ethernet port on a supported Savant controller.
3. Connect a straight-thru Ethernet cable from the RS-232 port on the Savant controller to the blue RS-232 adapter. 

Refer to Appendix A for information on the adapters required.
4. With the 9-pin DB9 gender changer supplied, connect the blue RS-232 adapter to the IR Learner.
5. Plug an IR Repeater/Flasher to IR port 1 on the controller. This will be used to test the commands captured.

Note: To test the commands, the IR port, RS-232 port, or the IP port can be used. This procedure uses the IR port.
6. Power on the controller by plugging the power supply into a 120V AC source.
7. Allow the controller to go through its startup diagnostics. The LED on the front of the controller will continually flash 

twice. This indicates the controller has acquired an IP Address. 
8. Optional: If the Savant Application Manager (SAM) is installed on the MacBook, select SAM and from the menu bar, 

launch the rpmEMBScanner utility (Launch > rpmEMBScanner). In the list of devices in the scanner, verify the 
Savant controller has acquired an IP Address.
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Load Profile into User Library
The first step is to load a profile into a User Library you created. Anytime a profile is going to be modified, it should be 
copied into the User Library and the original file kept separate. In the example below, the profile is copied from the System 
Library directly into the User Directory. 

1. Create a directory on your MacBook (SDE). This directory will be used to store custom profiles you modify or create. 
Create the directory in a place that you can access it through the Profiler software. For information on creating and 
maintaining a User Library, refer to the Window Menu section above. The Testing a profile - Create User Library 
section also has information on creating and maintaining libraries.

2. With Profiler Software selected, go to File > Open from Library. In the Open From Library window, you can copy 
the profile from the System Library directly to the User Library. The next few steps describe loading the profile from 
the System Library to the User Library:

- Select the System Library and a list of .xml profiles will appear in the Profiles window.
- Search the Profiles window and find the .xml profile to be modified.
- Select and drag the .xml profile from the System Library into the User Library.

3. With the .xml profile now loaded in the User Library, select and highlight the User Library. The .xml profile just 
copied from the System Library will be available. Select the .xml profile and select the Open button. This will open 
the profile into a new Profiler window.

Configure Resource Actions tab to collect the IR Commands
The next step is to configure the IR Capture device box to accept commands from the IR Learner and input them directly 
into the Command String table.

1. Select the Resources Actions tab.
2. From the Interface drop-down menu, select IR.
3. In the IR Capture Device: box is a Choose Device.. drop-down menu. Select RPMTerminal from the list.
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4. Once RPMTerminal is selected, press the Start Capture button.
5. The RPMTerminal will automatically open and attach itself to the docking station on the MacBook. The Profiler will 

scan the local network and display all the Savant products on the network. Locate the controller through the UID and 
product name and select it. The Controller drop-down menu will automatically populate the Savant controller 
selected. The image below selects the SSC-0012 controller. However, this could be any of the Supported Savant 
Controllers in the network.

6. In the Control Port drop-down menu, select the IR Port the Repeater/Flasher is plugged into.
7. In the Control Port: drop-down menu, select the IR port the Repeater/Flasher is plugged into on the controller.
8. Select Launch System button when all settings are configured. 
9. The Profiler will now connect to the Global Cache IR Learner (GC-IRL) through the controller. When the system is 

connected and ready, both the IR Capture Device and RPMTerminal will display Connected.

Note: Once the Global Cache IR Learner (GC-IRL) is communicating with the Savant controller, the Red LED on the 
face of the IR Learner will illuminate red.

10. In the Profiler software, select and highlight the command you would like to capture. In this example, the Power 
Toggle command is being added to the profile.
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11. In the IR Capture box press the Start Capture button to start the capture process. The wording on the button will 
change from Start Capture to Stop.

12. Point the remote at the front of the Global Cache IR Learner (GC-IRL) device. Press the Power Toggle button and 
the command will populate itself as shown below. 

13. To test the command that was just captured, press the Test button for the command just captured. The Profiler 
software will send the command through the IR Repeater/Flasher to the 3rd party device. The 3rd party device 
should act accordingly. Also, the command is sent to the RPMTerminal where it can be viewed.

14. To save the modified profile, from the menu bar, select File > Save. 
15. In the dialog box that appears, enter a description of the modifications made and press Save. The file gets saved in 

the User Library > componentProfiles directory. This profile is now available in the RacePoint Blueprint application 
as long as the User Library is linked to Blueprint. Refer to the Add User Libraries to RacePoint Blueprint section 
above for information on this.
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Appendix A - RS-232 General Information
The Controller RS-232 connections are used to transmit serial binary data to a device for control and receive serial binary data from 
devices to display current status on the user interfaces.  Each port type can support multiple protocols that are determined by the 
logical connection within Blueprint.
Note: Savant recommends planning control connections and protocols to be used prior to building any cables and connecting 
equipment.  This will ensure that devices will respond to commands and will not be damaged by an incorrect cable configuration.

RS-232 Pinouts

RJ-45 to DB9 Adapters
Savant uses RJ-45 connectors for RS-232/422/485, other manufacturers devices may use the standard DB9.  To make 
connection easy, Savant offers RJ-45 to DB9 adapters in a variety of configurations that can be used for RS-232/422/485 
control.  Be sure and choose the adapter that provides a proper connection to the devices RS-232/422/485 port.  Refer to 
the manufacturers support for the devices configuration.

For more information on Savant RJ-45 to DB9 adapters, refer to the RS-232 Conversion to DB9 and RS-422/485 Pinout 
application note located on the Savant Portal.

 IMPORTANT! If you are using RJ-45 to DB9 adapters not supplied by Savant:

• Ensure that any wires required for communication/control are terminated within the adapter.
• Ensure that all wires NOT required for communication/control are NOT terminated in the connecter.
• Ensure that the unused wires in the connector are cut to prevent them shorting out, as they are still terminated in the RJ-45 

connector on the controller side.
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Appendix B - RPMTerminal Basics
The Profiler software calls the RPMTerminal whenever a command is sent from the Profiler software through the controller to a 3rd 
party device being tested. The fields in RPMTerminal when launched by the Profiler software are automatically populated with the 
information entered in the Control Interfaces tab of the Profiler software. The information below describes the fields in the 
RPMTerminal when RPMTerminal is launched by the Profiler software.

Launching RPMTerminal through Profiler
RPMTerminal is launched from within the Profiler software. There is no need to launch RPMTerminal separately. There are a 
few methods used to launch the RPMTerminal from within the Profiler software. The method used to launch the 
RPMTerminal determines the functions that are available in the Terminal. Below are the two methods that can be used to 
launch RPMTerminal from within the Profiler software.

Method 1: Launch RPMTerminal through Test button
1. After the Profiler software is open and a profile is loaded, select the Resource Actions tab.
2. Select the interface from the Interface drop-down menu (IR, RS-232, IP).
3. Press the Test button to the right of the command that is being tested. The Profiler will locate the Savant controller in 

the network and display it in a drop-down menu. At this point, the RPMTerminal will open and attach itself to the 
docking station on the MacBook (SDE).

4. Select the Terminal to open it. The Message window is blank at this time.
5. Select Launch System button from the Profiler software. The controller will connect to the Terminal and messaging 

will scroll across the terminal indicating the controller is now connected to the terminal.

Method 2: Launch RPMTerminal through IR Capture Device drop-down menu
1. After the Profiler software is open and a profile is loaded, select the Resource Actions tab.
2. Select IR from the Interface drop-down menu.
3. Select RPMTerminal from the drop-down menu in the IR Capture Device Box.

4. Press the Start Capture button. The Profiler will locate the Savant controller in the network and display it in a drop-
down menu. At this point, the RPMTerminal will open and attach itself to the docking station on the MacBook (SDE).

5. Select the Terminal to open it. The Message window is blank at this time. 
6. Select Launch System button from the Profiler software. The controller will connect to the Terminal and messaging 

will scroll across the terminal indicating the controller is now connected to the terminal.
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RPMTerminal Command Menus
When the RPMTerminal is launched through the Profiler software, the menus available through the Command icon on the 
toolbar differ. The menus available are decided by what is selected in the Interface drop-down menu. 

Interface = IR, IP
When IR is selected, the available menus are displayed below. All the information about which equipment is connected is 
displayed. These menus are for display only. All commands should be sent using the Profiler software

Interface = RS-232
When RS-232 is selected, the available menus are displayed below. All the information about which equipment is connected 
is displayed. Notice that the RPMTerminal opened for RS-232 includes a panel that is exclusively RS-232. These menus are 
for display only. All commands should be sent using the Profiler software.

• Note the colored text in the RS-232 panel. This shows the color adapter that is currently connected. For information on 
each of the adapters available through Savant, refer to the RS-232 information in Appendix A.
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Appendix C: IR Translator
IR Translator Overview
The IR Translator is used to capture and translate IR Codes. When using the IR Translator software, the IR codes from a 
piece of equipment such as a remote control can be captured into the IR Translator software. The codes collected can then 
be copied into the Profiler Software where they can be tested and then added into an existing or newly created .xml profile.

Starting IR Translator Software
The IR Translator software should be started through the Savant Application Manager (SAM). The next few steps describe 
the recommended ways of starting the IR Translator. 

1. Open the Savant Application Manager (SAM). 
2. From the menu bar, select Launch > IR Translator.

3. The IR Translator window opens. Information on each of the fields is described below.

A
The drop-down menu lists all the IR protocols supported. If using the Global Cache IR Learner (GC-IRL), select 
GlobalCache IRL from this menu. Under the drop-down menu is a short description of the format used for the 
protocol displayed.

B

The IR Code captured by the IR Learner is displayed in this field. Each IR Protocol selected will have a different 
formatted message. For example, if Global Cache IRL is selected, the IR command captured will have GC-IRL at the 
beginning of each command:
Example Code captured by Global Cache:
GC-IRL,38000,341,169,22,20B,22,63BBBBBCCBCCCCCCBBBCBBBBCCCBCCC,22,3806

C The Clear button will clear the the Input field.

D The RacePoint Output field displays the IR Code translated after the Translate button is pressed. Once the code is 
translated, the code is copied and pasted into the Command Table of the Resource Action tab in the Profiler.
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E

In IR Control, the signal (or carrier) is used for noise rejection like guarding against interference from ambient light. IR 
Receivers use a band pass filter that is set to the carrier frequency as well as the IR Code fundamental frequency. 
This waveform is an unmodulated waveform.

When the Modulated PWM box is checked, the following waveform is sent

When applied to the unmodulated IR Code, the following waveform is sent:

If the Modulated PWM box is checked, the waveform below is sent:

Your IR code will have the 8th bit set high in Savant format to express unmodulated codes. For example: 
0000000100009470015600A9001600150015003F

However 99.9% of the time you will not have this bit set. For example: 
0000000000009470015600A9001600150015003F

This feature exists for wired IR implementations that don't need modulation, or don't accept modulation on the wired 
port. 

NOTE: Since our PWM ports (IR ports) are capable of sending a large variety of waveforms, you can easily 
accomplish actuator/servo control. The best solution is to keep the Modulated PWM box checked. Set the 8th bit to 0 
in the Savant IR format to fix a code if you captured it in the wrong mode.

F Pressing the Translate button will translate the IR Command displayed in the Input field to a command that the 
Profiler software can use. 

G A running log of the commands captured are displayed in the Input History field. The log includes a timestamp to 
distinguish between commands.

Translating an IR command
To translate the format of an IR command retrieved from a 3rd party to a format accepted by the Profiler software, do the 
following:

1. Open the IR translator through the Savant Application Manager. Go to the menu bar and select Launch > IR Translator.
2. The IR command retrieved from the 3rd party is in a specific format. From the drop-down menu, select the format that the 

IR command is currently in.

3. Copy the IR command to be translated into the Input window.
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4. To translate, select the Translate button. This will translate the code into the format that the Profiler and RacePoint 
Blueprint applications will accept. The translated code will be displayed in the RacePoint Output window.

5. Copy and paste the translated code to the profiler software for testing. In the screen capture below, the code for toggling 
an HD TV was translated.

6. Once pasted in the Profiler software, select the Test button to verify the command works as expected.
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Important Notice
Disclaimer
The contents of this document are subject to change without notice; therefore, the information presented herein shall not be 
construed as a commitment or warranty.

Savant Systems, LLC shall not be liable for any technical or editorial errors or omissions contained herein or for incidental or 
consequential damages resulting from the performance, furnishing, reliance on, or use of this material.

Patents
Certain equipment and software described in this document is protected by issued and pending U.S. and foreign patents.  

All products and services are trademarks or registered trademarks of their respective manufacturer. 

Copyright
This document contains confidential and proprietary information protected by copyright. All rights reserved. Copying or other 
reproduction of all or parts of this document is prohibited without the permission of Savant Systems. 

Trademarks
SAVANT®, RacePoint Blueprint®, and LiteWare® are trademarks of Savant Systems, LLC.
AirPlay®, Apple®, AirPort Express®, AirPort Extreme®, Apple TV®, Apple Remote Desktop™, FireWire®, iMac®, iTunes®, iPad®, iPad 
mini™, iPad Air™, iPhone®, iPod touch®, MacBook®, Mac® and OS X® are trademarks or trade names of Apple Inc., registered in 
the U.S. and other countries.
Android® is a trademark of Google Inc.
Wi-Fi® is a trademark of the Wi-Fi Alliance.
HDMI® is a trademark of HDMI Licensing, LLC.
Dolby® and the double-D symbol are registered trademarks of Dolby® Laboratories.
DTS® is a registered trademark and the DTS logos and symbols are trademarks of DTS, Inc.

All brand names, product names and trademarks are the property of their respective owners.

Technical Support 
Savant Systems LLC is dedicated to providing prompt and effective support.
To do this in a timely and efficient manner:
1. Access the Savant Portal
2. Enter your E-mail Address and Password. 
3. Read the Terms and Conditions statement. 
4. Select the check box to accept the Terms and Conditions.
5. Click Login.
6. The Savant Portal and Support Center Web page opens.
7. Select Support Request box.
8. The Submit a Ticket window opens.
9. Complete the information and click Finish.

Sales
Savant Systems LLC is dedicated to providing prompt and effective sales support.
Visit Savant.com to locate a local sales representative in your area.
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